Allar's Blog

Allar's Blog

RAIDMAX RX-700 PSU Sucks ass to the MAX!

A year and 3 months ago I bought an RX-700 power supply from Newegg. Newegg has never done me wrong with my plethora of PSU purchases along with other hardware, and I've never had a problem. I've tried all kinds of power supplies, ranging from starting from Antec ranging to the most generic. I must say, out of all the PSU's I have ever had, the RX-700 has definitely been the most disappointing.

For the first 8 months I had it, the power supply worked perfectly fine for my medium spec computer; however about 9-10 months in, I started getting random shut offs and blue screens. I attributed this to what I believed to be my faulty ram, but then when month 13 rolled around, just as the warranty expired, my cpu started becoming undervoltaged and no matter how I cranked up the bios voltage settings, I've seemed to be locked in at v1.1, same with my RAM. Things started getting unstable fast, but I knew I couldn't return it so I just had to deal with it.

It is now 3 days short of exactly 1 year and 3 months since I have had this PSU, and when I was copying over some critical school work files (for my Material and Lighting class), the PSU decided to just randomly die for what seemed to be no reason at all. I've tried multiple hardware setups and standard troubleshooting to confirm that the PSU is dead. It does not function enough to even output enough standby power to a motherboard.

I strongly encourage all of my readers to stay away from RaidMax products, especially PSUs, as I do not want to see anyone suffer from post-warranty-trauma.